steve_sprengel's profile
Champion

Champion

 • 

2.6K Messages

 • 

33.7K Points

Wed, Feb 26, 2014 10:49 PM

Closed

Acknowledged

Camera Raw: Long filenames truncated to approximately 60-something characters by ACR's Save Image... operation, example name also truncated

Long filenames are truncated to approximately 63 bytes in ACR 8.3/8.4's Save Image... panel. The name truncation happens to the file saved on disk and is visible in the Example Filename area.

It doesn't matter what file format is selected.

This didn't happen in older versions of ACR, according to the user initially reporting the issue.

Examples of truncation are:

HIETALAHTI, TENAVAMUSKARI_VAASAN SUOMALAISEN SEURAKUNNAN PÄIVÄKERHO_cpy004_5000_02.cr2

Saving as JPG becomes:

HIETALAHTI, TENAVAMUSKARI_VAASAN SUOMALAISEN SEURAKUNNAN P.jpg

which is 62 characters but the next character might need a double-byte to represent the vowel points so that would be too long at 64 bytes.

And if things are "cleaned up" regarding the comma and Ä then:

HIETALAHTI_TENAVAMUSKARI_VAASAN_SUOMALAISEN_SEURAKUNNAN_PAIVAKERHO_cpy004_5000_02.cr2

becomes:

HIETALAHTI_TENAVAMUSKARI_VAASAN_SUOMALAISEN_SEURAKUNNAN_PAI.jpg

which is 63 characters.

Here is a screenshot showing the truncation of the cleaned-up name:



The path the files are saved in doesn't seem to matter, where it can be long or short or under the users folder or off the root of the C: drive. This is happening on Windows 7, at least, and at least in ACR 8.3 and ACR 8.4 RC.

For references, here is the original message posted in the Adobe forums, bringing this issue to light:
http://forums.adobe.com/message/61509...

Official Solution

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

8 y ago

Thanks. The ACR team can repro and is looking into this.

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

8 y ago

Hi Steve,

This should be fixed in the final release of 8.4 if it's not already fixed in the 8.4 RC. Have you been playing with the RC?

Champion

 • 

2.6K Messages

 • 

33.7K Points

8 y ago

If you look at my initial post, you'll see it says, twice, that the issue happens in both ACR 8.3 and ACR 8.4 RC, and the screenshot says 8.4 beta at the top.

I am not an Adobe internal beta tester so the beta referred to is the RC.

This message thread was created Feb 26, while the RC was released Feb 21.

If another 8.4 RC is coming out, I'll look at it.

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

Sorry. I was quickly trolling bugs and saw the record was updated but didn't cross reference enough.

Sr. Product Manager, Adobe Digital Imaging

2 Messages

 • 

72 Points

8 y ago

Is there any update to this problem. I'm having the same issue and need it fixed asap.

Champion

 • 

2.6K Messages

 • 

33.7K Points

Are you using ACR 8.4?

If you read, above, Jeff T, and Adobe Associate, said it would be fixed in ACR 8.4 final. It seemed to be a problem in at least 8.3 and 8.4 RC.

2 Messages

 • 

72 Points

8 y ago

I think I was still using the beta! Thanks!