joel_sigerson_4214320's profile

126 Messages

 • 

2.6K Points

Fri, Feb 14, 2014 6:24 PM

Lightroom 5: opening wrong instance of Photoshop CC

Whenever I open a file in Photoshop from Lightroom, it launches Photoshop from a backup drive, if I have it mounted. This is more than a nuisance, my boot drive is much faster. The only fix is to unmount that drive and relaunch Lightroom.

I don't understand why Lightroom (which, rather inconveniently, doesn't allow me to manually enter the correct path) wouldn't default to checking for PS on the same volume as itself.

This conversation has been merged. Please refer the main conversation:

Lightroom: "Edit in PS 2014" opens PS 2014 in Wrong Location

Responses

Champion

 • 

2.6K Messages

 • 

33.7K Points

8 y ago

Here is a discussion about how to put back the Edit In Photoshop command if it is missing, so the locations and actions here may be slightly different, but the information should point you in the right direction to see if the issue is that the Photoshop path is wrong:
http://helpx.adobe.com/x-productkb/mu...

126 Messages

 • 

2.6K Points

8 y ago

That's not my issue. The Edit In Photoshop command is there, it works, but it launches a version of Photoshop on a different hard drive.

There's no way to manually select the path to Photoshop in Lightroom. As noted in "Additional Information" at the bottom of your link, Lightroom looks for the program itself without user intervention. However in my case, it defaults to an installation on a separate hard drive.

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

I had another customer have the same issue. I've asked the team to look into it. I'm not sure if it's something we can control or a goofy OS thing. Are you on Mac or Win? (OS/version)

Sr. Product Manager, Adobe Digital Imaging

126 Messages

 • 

2.6K Points

Mac OS X 10.8.5

126 Messages

 • 

2.6K Points

If I unmount my backup drive, I get an error that Photoshop CC could not be launched. Once Lightroom is relaunched, it happily launches PSCC off my boot drive.

I tried renaming the backup, and Lightroom complained, but still opened the wrong one.

Champion

 • 

1.1K Messages

 • 

21.6K Points

Is it possible that it is looking for the last one installed?

126 Messages

 • 

2.6K Points

I reinstalled Photoshop back when this started. I'll try reinstalling Lightroom.

Champion

 • 

2.6K Messages

 • 

33.7K Points

8 y ago

Your issue is that PS is being found at the wrong path when your external drive is plugged in.

On Windows the path LR is using is specified in the registry. Have you checked to see that the path in the registry is correct?