dieter_decroos's profile

14 Messages

 • 

228 Points

Sat, Aug 29, 2020 6:00 PM

Lightroom Classic: 10 Pictures do not sync.

Hi all,

I'm facing the same issue since a couple of days.

Followed instructions from above, deleted the pictures that was causing the issue, restarted LRC but now syncing is stuck on 10 remaining pictures with no apparent sync issues/ errors.

As some people indicated in the past: I'd be glad to hear any tips from you guys, or better yet, some help. It's a complicated issue, and I'd be very happy to make peace with my ever-turning syncing symbol.

Kind regards,
Dieter

Note: This conversation was created from a reply on: Lightroom Desktop: 1 Syncing Photo Never Syncs.

Official Solution

Adobe Administrator

 • 

1.2K Messages

 • 

20.3K Points

10 m ago

Updates to the Adobe Photography Products were released yesterday and include a fix for this issue. Please install the December update, restart your system and verify you are no longer experiencing the issue. Thank you for your assistance in reporting, providing additional information and, most of all, for your patience.

1 Message

 • 

62 Points

I've just installed the latest update and restarted my laptop.  Unfortunately, I am still having the same sync issues. I have 26 photos stuck syncing. They haven't synced to lightroom mobile at all. 

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

Dieter,

Please go to Help>System Info... and get us the exact installed version number of your software. 

14 Messages

 • 

228 Points

1 y ago

Lightroom Classic version: 9.4 [ 202008061458-dbb2971e ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.18363

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

Moving to a Lightroom Classic Thread

14 Messages

 • 

228 Points

Thank you Rikk, I'm here in the thread as well.

Kind regards,
Dieter

55 Messages

 • 

1.5K Points

1 y ago

It sounds like you've opened the sync activity tab in Preferences and it was empty. Is that right? Did you know that sometimes, it takes 30 seconds or more for Sync Activity to populate? Try waiting and see if it shows you the 10 photos that are stuck.

14 Messages

 • 

228 Points

1 y ago

Dear Alan,

thank you for your reply. Unfortunately, in my cases, even after I left my session open a full day, nothing happens...



This screenshot show situation after multiple hours online and connected during several days since last 10 days...

Kind regards,
Dieter

55 Messages

 • 

1.5K Points

1 y ago

Dieter. I may have misread your original post. I thought you were not seeing anything in Sync Activity. Now, I see that your photos are stuck in sync. Classic will show them as "uploading" forever.

Did you check Lightroom Web to see if they have actually been uploaded? In my experience, the stuck photos do get uploaded to the cloud, but for some reason, Classic never gets notified, so it thinks they're still uploading.

14 Messages

 • 

228 Points

Correct Alan,

They have been uploaded, but still the error remains visible...

Kind regards,
Dieter

Employee

 • 

74 Messages

 • 

1.1K Points

1 y ago

Hi Dieter, 

Can you generate the sync diagnostic logs and upload it to some shared location (dropbox ?) and share the link with me. You can generate a diagnostic report by going to Preferences->Lr Sync tab and hold down the option/alt key button. Click the “Generate Diagnostic report” button.

14 Messages

 • 

228 Points

Dear Ragrawal,

I have the diagnostic report ready. How do I share the link?

Kind regards,
Dieter

14 Messages

 • 

228 Points

Please inform when downloaded...

Employee

 • 

74 Messages

 • 

1.1K Points

I have downloaded the logs. Seems like there is a bug in 9.4 which is not clearing up the sync UI numbers. Sync is happening all fine but numbers are stuck. We are looking into this.

14 Messages

 • 

228 Points

Dear Ragrawal, any progress here? It seems there are others out there suffering the same issues but nothing is happening...

 

Appreciate your feedback.

 

Kind regards,

Dieter

245 Messages

 • 

4K Points

1 y ago

This reply was created from a merged topic originally titled synching for more than 24 hours.

Running LrC 9.4.
"LOCAL ACTIVITY" ( cloud top right corner) has been actively trying to sync 12 images for more than a day.
I believe I have found the 12 images - they all have a sync sign top right corner of thumbnail with a little line under it. Placing the cursor on the sync symbol gives me the message:

"Building smart preview for Lightroom ecosystem"

I recently renumbered the files and made some adjustments, but they seem to be appearing correctly on the website.

Any thoughts as to how to finish the syncing?

Thanks

1 Message

 • 

62 Points

I'd like to offer a third choice to Alan's list, which is to delete the "YourCatalogName Sync.lrdata" folder wherever your catalog file is stored. It will recreate. That has reliably unstuck my recent encounters with this exact "Building Smart Preview" issue (even if it doesn't appear that way at first). It does not prevent recurrence of  the problem which Adobe clearly needs to fix. But it does seem to allow syncing to actually complete in a more satisyfing way.

3 Messages

 • 

86 Points

This is currently the workaround that quickly resynced many pictures on my side.

55 Messages

 • 

1.5K Points

1 y ago

Jim: Until Adobe fixes this bug, you have two choices.
  1. Stop syncing the 12 images. Do this by selecting them, then navigating to the Catalog subpanel. Click on "All Synced Photographs". Press the Delete key on your keyboard. You'll see the message that "1 Photo will be removed  ... " Click OK. Do this for all 12 images. These will then be removed from the cloud, but now, in LR Classic, sync will show as completed.
  2. Ignore them. If you really need these 12 images on the cloud, just ignore the Local Activity indicator. Other images will still sync properly.


Good luck.

14 Messages

 • 

228 Points

Thanks for the feedback Alan, but Ragrawal declared this as a bug, would assume for a reputated company like Adobe to fix this shortly...

56 Messages

 • 

560 Points

I also find that unhelpful. What I have found as a workaround is:
- identify the photos in Classic that are stuck
- delete them from Classic
- import them again using the Cloud
This seems to sort if for me. Why this route? I use the Cloud for all imports and want to have all my photos there, so the idea of let's just delete them from the cloud is unacceptable.

8 Messages

 • 

250 Points

@alan_haynes thank you, this worked for me. Also, this was the only thing that worked. Rebuild Sync seems an overkill for one stuck file. Also, I don't see this in you recommendations, but I readded the stuck file to a synced collection, and it synced. Not right away, but it did.

19 Messages

 • 

384 Points

1 y ago

Via Tim Grey, this worked for me:

 

> Go to the Lightroom Sync tab within the Preferences dialog and hold
> down the Alt key on Windows or the Option key on Macintosh. This will
> reveal a "Rebuild Sync Data" button. While holding the Alt/Option
> key, click on that "Rebuild Sync Data" button, and then click the
> Continue button in the confirmation dialog.

14 Messages

 • 

228 Points

For all following this thread, this is the only solution today that worked for me.

 

Kind regards,

Dieter

11 Messages

 • 

200 Points

I had images stuck on "Building smart preview for Lightroom ecosystem" and this worked for me as well, although it took maybe 5 or 10 minutes for 17 photos. I keep Lightroom updated, but version is:  

Lightroom Classic version: 10.1.1 [ 202101041610-8c69aa4e ]
Operating system: Windows 10 - Business Edition
Version: 10.0.19042

3 Messages

 • 

86 Points

That unfortunately did not work. I shutdown LR C, removed the "YourCatalogName Sync.lrdata" folder and restarted LRC, reactivated sync and all pictures were successfully sync. Definitely a bug to be solved. I captured an LRSync diagnostic file that I would love to provide to support.

7 Messages

 • 

80 Points

1 y ago

I’m experiencing the same issue. All photos have sync’d, but LR Classic shows a rising number of photos waiting indefinitely  to be synced, with no sync errors. BTW, I wouldn’t recommend rebuilding sync data. When I did that, the number of “stuck” images skyrocketed from 15 to 150+. And the number continues to to rise. Last I checked, it was up to 167.

 

 I’m relieved to discover that this is a known bug. I just wish Adobe support had been aware of this before I spent nearly three hours over three separate chats trying, unsuccessfully, to troubleshoot this. 

7 Messages

 • 

80 Points

I’m glad this issue has been resolved for some, but nearly a year later not only has it not been resolved for me but the gentleman from Adobe who was helping me (you know who you are) has stopped responding to me, with no explanation. Frankly, I’m fed up with Adobe “support” and if I could find alternatives to the products I now use, from a company where the word “support” actually had meaning, I’d switch. 

1 Message

 • 

10 Points

1 y ago

I have the same problem. I did the Tim Grey trick to stop syncing until Adobe fixes it.

 

(edited)

1 Message

 • 

60 Points

1 y ago

I have the same probem, but I am non able to find the 18 photos which does not syncr ( I think they are photos I edited in Photoshop