R

1 Message

 • 

70 Points

Thu, Dec 17, 2020 5:06 PM

Closed

Lightroom Classic: 10.1 freezes Mac

Mac Pro (Late 2013) 3,7 GHz Intel Xeon E5 quad-core - 32 GB 1866 MHz DDR3 - AMD FirePro D300 2 GB . Big Sur

LR user since first versions, so many years ago. Always satisfied user untill a few days ago when I was till with Mojave and upgraded to LR Classic 10.1 which soon freezes the Mac when use  the develop module (library worked ok). It forces to an hard shut down pushing long the power buttons. I repeated more times and it always happened.

Unistalled and installed again with the same result.

Only solution as suggested in the user forum is to disable the GPU from LR preferences. Did not use it for a long time but it seems to work for the moment. I later upgraded to Big Sur, still works with GPU disabled.

Is the temporary fix temporary and Adobe is working on this bug which affects many users as everyone can read in the user forum or is the temporary fix something definitive? Any comment from Adobe?

Please do not mention it is due to the old machine I use because I read it happens also to 2020 macs users, again rerad in the users forum!

I would appreciate any comment from Adobe, thanks

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

2 Messages

 • 

70 Points

1 y ago

same issue with Lrc 10.1, MacBook Pro 15 2015, Mojave 10.14.6

1 Message

 • 

60 Points

1 y ago

Same issue with Lrc10.1, Mac Pro (late 2013), 3,7 quad core intel Xeon E5 + AMD FirePro D300 2 GB. OS 10.14.6 System freezes. I tried to format the disk and reload everything again. Lightroom starts and after a while, it completely locks the system.

(edited)

3 Messages

 • 

84 Points

Same Mac and same problem

1 Message

 • 

64 Points

1 y ago

Big Thank you from me, disable the GPU from LR preferences appears to solved my problem.

1 Message

 • 

60 Points

1 y ago

Same issue
MacBook 15" 2015, AMD Radeon R9 M370X 2 GB, Catalina 10.15.7

Champion

 • 

6K Messages

 • 

103.7K Points

1 y ago

Another option is to roll back to LR 10.0:

https://www.lightroomqueen.com/roll-back-update-previous/