C

2 Messages

 • 

80 Points

Mon, Oct 19, 2020 11:42 PM

Closed

Lightroom Classic 9.4: Error can't use the catalog because it is too new and to choose another

Every time I open lightroom it tells me that I can't use the catalog because it is too new and to choose another. My photos won't open and all my NEF files can't be found.  

Is there a fix for this?

2.3K Messages

 • 

26.4K Points

1 y ago

Can you post a screen capture of this dialog? 

1.2K Messages

 • 

13.1K Points

1 y ago

Seems like you are trying to use an old version of Lightroom with a new catalog. Did you get this copy of Lightroom from Adobe? 

 

This commonly happens to folks who buy a used computer that supposedly comes with licensed version of Adobe software, only to find out that they are the victim of a scam. 

2 Messages

 • 

80 Points

I did get this copy from Adobe.

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

Please go to Help>System Info… and get us the exact installed version number of your software. 

Is it possible you are opening a 9.x catalog on an 8.x instance of Lightroom? That would explain things. 

Adobe Photography Products

Quality Engineering - Customer Advocacy