vitkovalcik's profile

54 Messages

 • 

1.1K Points

Wed, Nov 4, 2020 6:38 AM

Closed

Solved

Lightroom Classic: Export JPG with _excluded_ keywords + import JPG = no keywords in LR

I am on current Windows with LR Classic 10.0 and trying to create an archive JPEG files from Raw files while remembering all the keywords.

While exporting the JPEG the "All metadata" is selected and "Write Keywords as Lightroom hierarchy" is checked and this will export even the keywords for which the option "Include on Export" is NOT checked.

In other software I can confirm that there are XMP tags inside the JPEG file itself of type lr>hierarchicalSubject containing the keywords. But back in Lightroom after importing the file, the keywords are not displayed. (It works for the keywords that have "Include on Export" checked in their properties though)

I had the impression that this worked before, it may be a newer bug.

Accepted Solution

656 Messages

 • 

11.6K Points

1 y ago

While exporting the JPEG the "All metadata" is selected and "Write Keywords as Lightroom hierarchy" is checked and this will export even the keywords for which the option "Include on Export" is NOT checked.

That does not appear to be the case for me.  Using the following keyword hierarchy - 

Level_1

--Level_2A

----Level_3A

--Level_2B

All keywords have "Include on export" checked with the exception of "Level_2A".

Added all keywords to an image.

Exported image with "All metadata" & "Write as Lr hierarchy" options.

Searching through the exported file, I could find no instances of the "Level_2A" keyword, as expected.  With its parent missing, "Level_3A" was written under "Level_1", so the resulting hierarchy looked like this - 

Level_1

--Level_2B

--Level_3A

54 Messages

 • 

1.1K Points

Thank you for the test! I redid my test as well and I can see the issue - not with the original problem, but with the test I did.

The export & import thing is still a problem, the keywords are missing and this wasn't the case with older LR version. It means changed behavior, but probably not a bug.

But you are right, it is on the export side, the keywords are not there. I made a mistake and used another app -  XnView - to view  the JPG file. However next to the file there was the original XMP file and XnView merged tags from those two files together before presenting them to me, even though I was looking at the JPEG.

So I will mark your answer as accepted. There was a change: The keywords marked as not to be exported are now actually not exported... not sure if I should report it call it a bug or a fixed code :) I will have to find a workaround though.

(edited)

1.2K Messages

 • 

13.1K Points

1 y ago

Since JPEGs don't have XMPs, I'm not following your question. XMPs are only for raw images and not JPEGs, DNGs, TIFF/TIF, etc. 

54 Messages

 • 

1.1K Points

@bill_3305731

Oh, I meant the XMP tag inside the JPEG file, similar to EXIF or IPTC tags. Not the XMP file. I will clarify it in the original post.

245 Messages

 • 

4K Points

1 y ago

Including "Do not Export" keywords was something that I discovered in ver 9.4. So it isn't new to Ver 10.

I don't worry about as I don't use keywording outside of LR, but I can see it being a nuisance for you.