serafin_garcia's profile

4 Messages

 • 

150 Points

Mon, May 31, 2021 10:52 PM

Closed

Lightroom Classic: Files getting deleted from PC on upload to Smugmug website

I first observed this issue around 15 May. Smugmug support tells me that the problem cannot possibly be something on their end of the Smugmug Publishing Manager.

 

When I upload new images (HEIC files from my iPhone 11 Pro) from my Windows 10 PC hard drive to the Smugmug website using the Publishing Manager, the images succeed in uploading, but then the files disappear from my hard drive. On any subsequent operations I attempt to perform on these images, Lightroom complains that it can no longer find the files. The files are no longer visible on Windows File Explorer. I've searched my hard drive for the missing files with no success.

 

The problem does not seem to happen when I re-publish existing images (that were uploaded before the problem started or that were subsequently restored). I have not had the time to fully exercise this scenario to confirm more definitively.

 

The unexpected deletion case has happened to me 3-4 times so far... pretty repeatable. Fortunately, in most cases, I had other copies of the deleted images which enabled me to restore them. I have lost at least a couple of originals; I had to rely on the JPG renderings on Smugmug to restore my local library.

 

What could possibly be causing the images to get deleted - these operations are supposed to be non-destructive. I've performed these operations hundreds of times in the past before the problem emerged ~two weeks ago.

 

I would be happy to discuss in greater detail with Adobe developers if needed.

Accepted Solution

4 Messages

 • 

150 Points

6 m ago

An update: I convinced SmugMug Support to escalate the issue to Engineering. I sent them a video demonstrating the situation and I had a fix back about five minutes later. I have no idea what the actual root cause was, but it must have been semi-obvious once demonstrated. All good now.

Champion

 • 

6.7K Messages

 • 

112K Points

6 m ago

Can you give us exact steps for how you're sending the photos to SmugMug? That might offer some clues. I can't think of a way Lightroom could do it, otherwise they'd simply disappear from Lightroom rather than be marked as missing.

4 Messages

 • 

150 Points

Thanks for chiming in and for sharing your knowledge/analysis.

I simply add the photos (from the Previous Import folder or from other folders in the library) to existing SmugMug galleries on Lightroom (under Publishing Services) and then select "Publish Now" on the context menu for the gallery.

I've done this hundreds or thousands of times before with no issues. The deletions are a recent thing.

I agree that if I am doing that something that would cause Lightroom to deliberately delete files, then it wouldn't be "surprised" to find them missing. This lends weight to the theory that the behavior is a bug and not a feature.