B

7 Messages

 • 

138 Points

Sat, Jan 23, 2021 3:39 AM

Lightroom Classic: import fails to combine ARW+JPEG when importing from a memory card "device"

When importing from a memory card as a "Camera or Card Reader" source, Lightroom sometimes fails to combine a jpeg file with its corresponding raw file.  When importing from that same memory card as a "folder", however, it usually seems to work fine.

See screenshots: https://imgur.com/a/fOWstWL (actual image contents redacted, but there are no changes to the card between the first two import dialogs)

This behavior occurs even after restarting Lightroom, or nudging it to re-scan the same folder.  It always happens on the same file, but I couldn't discern any difference between that file and the others ones whose jpeg/raw files are grouped correctly.

As for the two files that are not combined, they have the same modification time, same basename, and same capture time according to EXIF data.

1.2K Messages

 • 

13.1K Points

9 m ago

While getting this fixed is certainly desirable, its been a problem across many versions of Lightroom. So for me the practical solution has been to always copy from a camera, memory card or memory stick to a folder on a drive. Then the images import correctly.

  

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

9 m ago

Are you connecting to a Card Reader or a Camera?

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

9 m ago

It may be as simple as a preference file reset: 

Reset Procedure:

1. Close Lightroom.

2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.

3. Overwrite the Preferences when prompted by the dialog.

4. Close Lightroom.

5. Restart Lightroom.

7 Messages

 • 

138 Points

No luck with the preference reset, I'm afraid.

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

9 m ago

Circling back to your first post:

To be treated as raw+sidecar - they files need to be in the same folder and have the same name. Can you verify?

7 Messages

 • 

138 Points

Yes, indeed, they have the same folder and same name, just like the files next to them.  If it would be helpful, I can perhaps upload a zip of the images somewhere for troubleshooting purposes, and pm/email you a link?

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

If you could, into a single folder place:

1 - raw & matching JPEG where import functions correctly

1 - raw & matching JPEG where import fails 

Zip that folder into a single file. When you are ready, I will send you instructions for transmitting. 

Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

138 Points

I've uncovered a bit more information when trying to pull out a set of files for you.  It appears that which file pair fails to import correctly can change, depending on what other files are on the device.  There appears to be a threshold of file count below which the bug doesn't appear.  I can send you a zip file of a problematic folder, but it's quite big (1.5GB).  Let me know what you would like to do, and thanks for helping troubleshoot this detail.

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

That is pretty big - how small does it zip down to?

Adobe Photography Products

Quality Engineering - Customer Advocacy

7 Messages

 • 

138 Points

Ah, okay.  Since the actual contents of the file don't seem to matter at all, I can just send you a pair of files and a list of file names.  I was able to reproduce the issue when just making many copies of a single raw file and a single jpeg file into multiple names.  Please let me know where you would like me to send it.