stefan_kemar's profile

9 Messages

 • 

150 Points

Tue, Oct 27, 2020 6:00 PM

Closed

Lightroom Classic: Profile browser loads quickly for unedited images and slowly for already edited ones (video included)

I have amassed a lot of color profile, I'm aware. However, when opening the profile browser while viewing an image that's already been edited, it takes upwards of 10 seconds, as opposed to be instant with unedited images. This is with graphic acceleration enabled and my machine is far from outdated or sluggish in any other respect.

Video linked below

https://streamable.com/0afdwj 

 

System specs below

Lightroom Classic version: 10.0 [ 202010011851-ef6045e0 ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.16.0 [20A5395g]
Application architecture: x64
Logical processor count: 16
Processor speed: 2.4 GHz
SqLite Version: 3.30.1
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 9,544.1 MB (29.1%)
Virtual memory used by Lightroom: 26,903.0 MB
Memory cache size: 314.8MB
Internal Camera Raw version: 13.0 [ 610 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1676MB / 16383MB (10%)
Camera Raw real memory: 1943MB / 32768MB (5%)
Displays: 1) 3360x2100

Graphics Processor Info:
Metal: AMD Radeon Pro Vega 20

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Users/stefan/Pictures/Lightroom/Lightroom Catalog-v10.lrcat
Settings Folder: /Users/stefan/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Facebook
4) Flickr
5) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (MacBook Pro Speakers)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: LR5x42
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon Pro Vega 20 OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-4.0.43
OGLEnabled: true

-ST

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

I am not able to replicate this behavior.  An edited file and a pristine file take the same time to load the Profile Browser.

When you say: "I have amassed a lot of color profile" can you give us an estimate of how many you are talking about?

9 Messages

 • 

150 Points

@Rikk I'm talking in the neighborhood of 2000 or just above. 

-ST

168 Messages

 • 

2K Points

@Rikk Did you notice the MACOS 

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

10.16 is not really valid. I am guessing that it is a Beta version of Big Sur which isn't yet supported. 

Adobe Photography Products

Quality Engineering - Customer Advocacy

9 Messages

 • 

150 Points

@Rikk Thanks for chiming in. With Big Sur to release within the next month and the beta had been available for about 4 months or so I still see this as worthwhile feedback for the dev team to take into consideration. I've also noticed while the profile browser is open and I switch to another image (edited or not) there is quite a delay to render the preview. If these are in fact Big Sur related then given the size of the user base it would pertinent to highlight these performance issues going forward. 

I've also reported them to Apple directly through the beta channel feedback. 

-ST