sandro_2531566's profile

6 Messages

 • 

154 Points

Tue, Apr 7, 2020 5:25 AM

Lightroom Classic: Toggling B&W Deletes all Radial Filters, Graduated Filters, and Adjustment Brushes

The title pretty much sums it up. Create any combination of Radial Filters, Graduated Filters or Adjustment Brushes on your image. Make the image B&W (V). Toggle the B&W Adjustments off and you lose all of your adjustments. 

REPRO:
- launch LR Classic
- D to edit an image
- add any combination of Radial Filters (shift+M), Graduated Filters (M) or Adjustment Brushes (K). Just one will suffice. 
- V to convert to B&W (starting in B&W has the same effect)
- turn off the B&W adjustments (this is the HSL tab if the image is in color)

RESULT: All adjustments are gone. Poof! 
EXPECT: All adjustments to remain in place. 

LR Classic: 9.2
macOS: 10.14.6

Responses

644 Messages

 • 

9.7K Points

1 y ago

What does the History list section show?

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

I cannot reproduce this behavior using 9.2 on 10.14.6. The Local Adjustments stay intact. 

Just Shot Me's comments are a good troubleshooting step. Watch the History panel as you do this and see what happens there. It might offer a clue as to what is going wrong on your system. 

I am not sure what you mean here: "(this is the HSL tab if the image is in color)"

6 Messages

 • 

154 Points

Please see the image of my history attached below. 

630 Messages

 • 

12.5K Points

1 y ago

I can confirm this behaviour on Windows, too, Rikk. Also, what he means is that the HSL tab is, well, HSL for a colour image and it changes to B&W when it's B&W. I think Sandro's just trying to make it clear which tab he's referring to when he says "B&W adjustments"

285 Messages

 • 

5.1K Points

1 y ago

I can not reproduce it using 9.2 on Windows 10.0.18362

630 Messages

 • 

12.5K Points

1 y ago

Yup, that's a strange one indeed

6 Messages

 • 

154 Points

That's precisely what I'm seeing. Thanks for the visual! 

Champion

 • 

2.4K Messages

 • 

39.2K Points

1 y ago

I can confirm the issue is present on my Windows 10 system using LR 9.2.

47 Messages

 • 

828 Points

1 y ago

I can not reproduce it on Mac OS 10.14.6 and LR 9.2.
Adjustments remain — both those applied in colour before -V, and those applied while in B&W — when back in colour after another -V

47 Messages

 • 

828 Points

Apologies.  When using -V to toggle back and forth between BnW and Colour, the adjustments and the pins remain.  Toggling the BnW mix panel does indeed lose the adjustments and the pins.

380 Messages

 • 

6.7K Points

1 y ago

Confirming the problem using Lr 9.2 with Windows 10.

With local adjustments applied, use the V key or click Black & White in the Basic panel to change Treatment to Black & White. Go to the B&W panel (HSL/Color in colour mode) and turn off the Black & White Mix using the small toggle switch.

Local adjustment pins vanish.

Switching the Black & White Mix back on doesn't restore the local adjustments and neither does convertring back to colour using the V key.

Pretty serious bug I'd say.

6 Messages

 • 

154 Points

1 y ago

Someone asked to see the history. Here you go. The Update Exposure Adjustment was performed to make the adjustment area more visible. Note that the pins will reappear with an undo. 



Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

Ok. It appears I can only get the bug to manifest by toggling visibility on the B&W Panel. Thanks for the video Jerry. 

Double check my steps to reproduce:

  1. Place Local Adjustment on Image
  2. Convert to B&W ( [ V ] KBSC or Black & White in Treatment
  3. Toggle off visibility for B&W Panel
Actual: Local Adjustments disappear
Expected Local Adjustments remain. 
Workaround: Use Undo

6 Messages

 • 

154 Points

That's it, precisely! (and concisely)

10 Messages

 • 

342 Points

1 y ago

Interestingly, if you start your edits with the b&w panel toggled to the off position, you can't even create a brush stroke that stays.

6 Messages

 • 

154 Points

Good observation. I just confirmed this. 

Adobe Administrator

 • 

10.9K Messages

 • 

143.5K Points

1 y ago

Version 9.3, an update to Lightroom Classic, went live on June 15, 2020 and contains a fix for this issue. Please install the update and respond back if it does not cure the issue for you. Thank you for your patience!

Champion

 • 

2.4K Messages

 • 

39.2K Points

1 y ago

Rikk, LR 9.3 has fixed the issue on my Windows 10 system.