tony_jagodnik's profile

3 Messages

 • 

132 Points

Fri, Jan 17, 2020 7:07 PM

Lightroom Classic v9.1: Sort filter turns off unexpectedly

After doing  a photo merge, either HDR or pano, LR switches the sorting filter in use to "No Filter". Adobe support, while remotely controlling my MacBookPro, said that is normal, but to me it is a bug. Why does it do that? In what other cases does the filter unexpectedly turn off? Could a feature be added to leave the filter as set?

I am just learning LR and am working on >10K pix from Antarctica. I use the star rating, with 1 star for images that might be good, but are duplicative or have been included in an HDR or pano or have GPS data, but i don't want to delete them. So i usually have the filter set to 2 stars or better. When the filter shuts off after a PhotoMerge, all of a sudden thousands of one-star pictures annoyingly appear in the grid and filmstrip.

Responses

656 Messages

 • 

11.6K Points

2 y ago

Hey Tony - Try setting the lock on the filter bar.  I think that will get you the behavior you're looking for.


3 Messages

 • 

132 Points

2 y ago

Thanks, but the lock in mine shows that it is locked, but won't change when i click on it. Nor does it show the dialog box in your picture.......will not disable with ????

656 Messages

 • 

11.6K Points

2 y ago

That white box in my screen grab is the tooltip that shows up when you hover over the lock.  The full text reads "If locked, the filter will not disable when changing sources", which is exactly what you want to happen.

Can you post a screenshot of what you're seeing?  It may be easier to troubleshoot what you're doing.

3 Messages

 • 

132 Points

2 y ago

You are right! Thank you. I looked closer at the tiny lock (see screen print) and found that it only changes a few pixels in height, so it doesn't appear to change. PROBLEM SOLVED!