John_R_Ellis's profile
Champion

Champion

 • 

6K Messages

 • 

103.7K Points

Thu, Oct 24, 2013 4:44 PM

Closed

Acknowledged

Lightroom: Many bugs with videos and smart-collection dimension criteria

In LR 5.2, there are many bugs with videos and smart-collection dimension criteria. In particular, these criteria do not match any of the .mp4 and .avi videos I tested with:

Cropped is false
Long Edge is greater than 0
Short Edge is greater than 0
Width is greater than 0
Height is greater than 0
Width, Uncropped is greater than 0
Height, Uncropped is greater than 0
Megapixels is greater than 0.0

(Megapixels is defined for images simply as width x height / 1,000,000; should be the same for videos.)

Strangely, the following criteria do work correctly for the tested videos:

Long Edge, Uncropped greater than 0
Short Edge, Uncropped greater than 0
Megapixels, Uncropped is greater than 0.0
Aspect Ratio is landscape

Official Solution

10 Messages

 • 

250 Points

8 y ago

Hi,

I can reproduce the issue you mentioned, and this should be a bug. I will open a bug for this.

Thanks,
Chunxia
Lightroom QE

Champion

 • 

6K Messages

 • 

103.7K Points

Thanks.

Champion

 • 

6K Messages

 • 

103.7K Points

8 y ago

This reply was created from a merged topic originally titled
LOIGHTROOM 5.2: Smart-collection criterion Height doesn't work with videos.


The smart-collection criterion Height does not work for at least some MP4 videos in LR 5.2 Windows 7 64-bit. As an example, the Metadata pane shows my MP4 videos having dimensions of 1440 x 1080:



But this smart collection doesn't match that video (or any others):





But the Metadata panel and the SDK's photo:getRawMetadata() report valid dimensions: