davidbleja's profile

117 Messages

 • 

3K Points

Sat, Mar 7, 2020 1:48 AM

Closed

In progress

Photoshop 21.1.1: Artboards get messed up when dragging multiple artboards

I found a bug that I don't think existed before 21.1.0. When mouse-dragging multiple artboards, they glitch out, with the artboards and their contents getting out of sync with each other and jumping to unexpected areas of the canvas.

Please see GIF below (also here: https://gph.is/g/Ev151vV )


117 Messages

 • 

3K Points

2 y ago

This problem still exists in 21.1.1, even though that update was said to address some other canvas positioning errors. 

10 Messages

 • 

310 Points

2 y ago

This reply was created from a merged topic originally titled Photoshop: Artboards don't stay in place when you drag multiple artboards, they j....

Artboards don't stay in place when you drag multiple artboards, they jump to a different location. Fix the problems with dragging in Photoshop!

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

2 y ago

@David, would it be possible to get a copy of your file? Engineering has not been able to reproduce exactly what you're seeing.

117 Messages

 • 

3K Points

Here's a simple PSD that I can confirm displays similar problems on my end: https://1drv.ms/u/s!ArgAg1qAY1amkalEhPel0Mwy30bcvQ?e=w8AS9e

If it doesn't have problems immediately, just keep dragging multiple artboards around at different combinations of distances and zoom levels, and the glitches may emerge.

It seems like complexity has something to do with the problem: on my large PSDs with dozens of artboards and hundreds of layers, the glitches are more or less constant, immediate, and severe. Though this new PSD that I just uploaded worked fine for the first little while, but eventually showed the same types of glitches when I persisted.

I've noticed that it may be a display issue only, as if I save the file (or sometimes, change zoom level) then everything seems to pop back into where it's supposed to be. Perhaps a GPU-rendering issue? 

I can give you the original file screenshotted above if you give me a private channel through which to do so. 

Also let me know if you need any of my software/settings/hardware details

117 Messages

 • 

3K Points

FYI
I've just upgraded my nvidia driver (from 436.48 to 445.75), in case that was the issue, but the problem still persists. 

Also, turning off "use GPU" in PS settings doesn't help either. Performance is greatly decreased, but the glitches are still there. 

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

Thanks. Let me see if that helps us reproduce. Will let you know.

Sr. Product Manager, Adobe Digital Imaging

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

Curious if disabling rulers makes this behave better?

Sr. Product Manager, Adobe Digital Imaging

117 Messages

 • 

3K Points

No, enabling/disabling rulers/grids/smartguides doesn't seem to make a difference. Neither does enabling/disabling "Auto-size canvas" in Artboard options bar