photoshop_faq's profile
Adobe Administrator

Adobe Administrator

 • 

158 Messages

 • 

14.3K Points

Fri, Apr 8, 2011 7:11 PM

Closed

Solved

Photoshop: Selecting Save for Web gives error: "Could not complete this operation. An unknown operating system error has occurred."

When I select Save for Web if displays an error: "Could not complete this operation. An unknown operating system error has occurred."

Official Solution

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

11 y ago

Reset Photoshop's Save For Web preferences:

1. Quit Photoshop
2. Delete the "Adobe Save For Web 12.0 Prefs" file:

Mac: Users/[Username]/Library/Preferences/Adobe Save For Web 12.0 Prefs

Windows XP: Documents and Settings/[Username]/Application Data/Adobe/Save For Web/12.0/Adobe Save For Web 12.0 Prefs

Windows 7 and Vista: Users/[Username]/AppData/Roaming/Adobe/Save For Web/12.0/Adobe Save For Web 12.0 Prefs

2 Messages

 • 

72 Points

Your solution did not solve this problem for me. But this solution did:

Delete the following preference file:

/Users/[username]/Library/Preferences/Adobe/Plugins/Adobe Save for Web CS5/Photoshop/Adobe Save for Web CS5 Prefs

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

Thanks. I'll update the path.

Sr. Product Manager, Adobe Digital Imaging

2 Messages

 • 

72 Points

It's possible that both files need to be deleted, because I tried your method first and when that didn't work I tried the other method. Or for some people maybe it's one and others it's the other.

42 Messages

 • 

1.3K Points

FYI, For Windows Vista / 7 the Path is:

C:\Users\[user]\AppData\Roaming\Adobe\Plugins\Adobe Save For Web CS5\Photoshop\

1 Message

 • 

60 Points

i do not have plugins folder either i can't find adobe saver for web cs5
i am using cs6

4 Messages

 • 

100 Points

10 y ago

I have the same problem on a recurring basis. I have deleted both preference files in Library:
Library/Preferences/Adobe Save for Web 12.0 Prefs
Library/Preferences/Adobe/Plugins/Adobe Save for Web CS5/Photoshop/Adobe Save for Web CS5 Prefs
and then the problem goes away only for a short period before it resumes.
I also in desperation deleted the whole folder:
Library/Preferences/Adobe/Plugins/Adobe Save for Web CS5/

Photoshop always immediately rewrites all these. But the problem recurs.

I have recently installed CS5 Design Suite 5.5 Design Premium on a new iMac12,2. My Photoshop is 12.1.

Adobe Administrator

 • 

16K Messages

 • 

296.7K Points

Hi Robert, would you mind if I contacted you directly through email and get a set of the problem preference files from you for investigation?

Sr. Product Manager, Adobe Digital Imaging

4 Messages

 • 

100 Points

please do. I'll be here for the next hour.

1 Message

 • 

62 Points

10 y ago

I have the exact same error and tried deleting both files but it simply wont work.
Would it perhaps be possible to replace them with someone elses working preferences? or do I need to reinstall?

1 Message

 • 

80 Points

10 y ago

If you're on a Mac I was having the same issue and it was related SIMBL. I uninstalled SIMBL and any apps which required it and Photoshop started working properly.

2 Messages

 • 

72 Points

OMG. Searched on Google all day...YOU ARE MY SAVIOR! SIMBL ftl people...SIMBL ftl.

1 Message

 • 

60 Points

Lucky you! :D

There was nothing like this when I was dealing with the problems so I did a clean install of Lion, installed CS5 trial and reinstalled each app I previously had. I tested CS5 after each app that I reinstalled.

I'm glad I helped someone by posting this.

2 Messages

 • 

72 Points

That would've taken me a week D: It's such a specific issue, I'm so glad you posted it...

1 Message

 • 

60 Points

10 y ago

I've deleted the prefs file as suggested above and I'm not getting it to work. Someone mentioned previously that it works for a little while and then resumes again. It is not working for me period. I'm running Photoshop CS5 12.0.4 on Mac OS X v10.6.8.

4 Messages

 • 

100 Points

10 y ago

I have CS5 12.1 x64 with Mac v10.6.8. There has been no problem for over 4 months now, but two days ago it recurred, just once. The file I wanted to save was a tif. I then saved it as a normal jpeg and then was able to Save for Web.

3 Messages

 • 

86 Points

10 y ago

Trashing that prefs file does not work.
CS5, OS X 10.6.8.

42 Messages

 • 

756 Points

9 y ago

I realize this is a year old but I'm suddenly hitting this issue with Photoshop 13.0.4 and Mac OS 10.7.5

Anything I try and Save for web presents...


I've deleted all Photoshop CS6 predf in ~/Library/Preferences including the com.adobe.photoshop.plist file

I've reinstalled the mac OS 10.7.5 combo update.

Rebooted several times

Repaired permissions and verified the disk.

Things were fine 3 hours ago, now no save for web completes. I've done nothing to alter the system between when it was working and now that it is not. All that has changed is the date.

4 Messages

 • 

92 Points

8 y ago

Using Photoshop CC, same issue here. On OSX 10.9

This is really frustrating...

15.1K Messages

 • 

195.8K Points

Well, the message is there for UNKNOWN operating system errors - things that we don't expect, haven't seen, and don't know how to handle.

Bugs in new operating system versions could cause that...

4 Messages

 • 

92 Points

8 y ago

Actually my message is slightly different.

Photoshop CC 14.1.2

15.1K Messages

 • 

195.8K Points

Does that happen after showing the save dialog? Have you tried changing it off of coverflow mode? (that's a known OS bug in 10.9)

4 Messages

 • 

92 Points

This error pops up when trying to change the directory to save the file.

I actually just changed it from coverflow mode, and so far it seems to be okay.

15.1K Messages

 • 

195.8K Points

Yep, sounds like you were hitting the known OS bug.

4 Messages

 • 

92 Points

Good to know. Thanks for your help!

42 Messages

 • 

756 Points

8 y ago

Note my resolution for the Mac OS when this occurs, which is random - perhaps once or twice a year it seems.

Navigate to....

[volume]/Users/[you]/Library/Preferences/Adobe/Plug ins/Adobe Save for Web CC (or CS6 or CS5)/Photoshop

NOTE: THIS IS NOT THE STANDARD PREF FILE LOCATION.

You'll find 1 file there.... a Save for Web preference file. -- Adobe Save for Web CC Prefs -- Trash that file. THAT seems to be the file which causes the error here, and not the file open in the preference directory.

Seems there are multiple preference files for Save for Web. I'm not sure why, but it is this buried file which causes the issue on my Macs.

1 Message

 • 

60 Points

8 y ago

I have run into this a few times in CC for Windows 7, and I have a solution for this--at least for me.

Whenever I "save for web" and save something to the root of C:/ it will work, but the next time I "save for web" it produces the error. I was able to fix it by going into User Account Control settings and scaling down to "never notify." It requires a reboot, but the next time I "saved for web" it worked fine.

If you do this, be sure to change the UAC back to "default" as it is a security measure.

FYI you will have to restart anytime you tweak UAC.

To change UAC in Win 7 go to control panel>Action Center>Change User Account Control Settings and drag the slider to "never notify."

6 Messages

 • 

120 Points

8 y ago

Having same issue - Mac OS X 10.9, Photoshop CC. I don't even have a library folder on this new computer so this link does nothing for me..
Users/[Username]/Library/Preferences/Adobe Save For Web 12.0 Prefs

Can anyone help?

42 Messages

 • 

1.3K Points

The Library folder is there, it's just hidden. Go to the Terminal application and type "open ~/Library" (no quotes), and it should show up.

42 Messages

 • 

756 Points

Choose Go > Go To Folder... in the finder and then type ~/Library in the box. That's (tilde)/Library. This will open the user Library folder even though it's hidden in more recent OS versions. You don't HAVE to use the terminal (it scares some) but the terminal method Foster posted works as well.

6 Messages

 • 

120 Points

tried deleting the file and it didn't fix the issue

6 Messages

 • 

120 Points

oh - and I can't even save something the normal way either. When I try doing that, the window to find the place to save the file just disappears with no error box.

42 Messages

 • 

756 Points

Nicole, read my post 2 posts above yours. There's a second, hidden, preference file that needs to be deleted. Simply removing the standard preference file won't help (at least it doesn't here). [volume]/Users/[you]/Library/Preferences/Adobe/Plug ins/Adobe Save for Web CC (or CS6 or CS5)/Photosho

1 Message

 • 

60 Points

7 y ago

Thank you so much. This worked for me great!!!!!!!!!!