patrick_mauldin_g5dlah66wzo7w's profile

16 Messages

 • 

722 Points

Thu, Feb 27, 2020 12:20 AM

Properties Panel Wont Save New Values When Typing

I don't even know how to title this but it is a VERY frustrating glitch. It has been happening for the last couple weeks with all parts of the properties panel from font name, to leading, font size. When I am in the middle of trying to input a new value, it will not recognize the new input and revert back to the old input.

Example: https://gfycat.com/teemingsecondarydungbeetle

Responses

2K Messages

 • 

35K Points

2 y ago

What OS are you running? I can see in your video that it's very frustrating, but I can't get that to happen here on my Mac running Mojave. I can see in your video, as well, that it's starting to select a font as you type, but then it suddenly disappears, reverting to the old name.  I've never seen anything like it before.

Is it just the Properties panel? Are you able to work with the Options bar, or does it do the same thing there? And if you don't input a value, but select from the dropdown lists, same thing, or does that work?

16 Messages

 • 

722 Points

Catalina 10.15.3

Its sporadic. Sometimes it happens, sometimes it doesn't. So hard even for me to replicate.

I'll try using another panel next time and see if its happening there as well.

16 Messages

 • 

722 Points

It happened again and I tried using the character panel and the glitch was happening there as well.

Adobe Administrator

 • 

3.5K Messages

 • 

53K Points

Yeah, it would only happen when you have text selected that contain a character which is NOT found in the new font selected.  So it would certainly seem random and sporadic.  Try with a very simple text string like "hello" and I believe you'll find the problem to be gone.

Thanks,
David

Adobe Administrator

 • 

3.5K Messages

 • 

53K Points

2 y ago

Hey Patrick,

Did you have text selected while you were doing this?

Thanks,
David

16 Messages

 • 

722 Points

Yes, I had text in my psd selected and it was live updating as Photoshop was constantly changing font names on me.

16 Messages

 • 

722 Points

It happened again and I tried using the character panel and the glitch was happening there as well.

Adobe Administrator

 • 

3.5K Messages

 • 

53K Points

Yeah, Patrick, if you have text selected and this is happening, Photoshop is actually trying to do you a favor.  You see, by default, Enable Missing Glyph protection is enabled.  You can disable/see this by going to Preferences > Type and it's the second checkbox from the top on the left.

Anyway, the way that feature works is if you have text and you change the font to a different font face that does not support all the characters you're using, we change the font to one that does for you.  So that's what you're encountering.  There is one or more characters in your string that are only supported by the font you're seeing and not other fonts.  Try a simple string like "abc" and you'll see it behave differently.

Hope that helps,
David

16 Messages

 • 

722 Points

the text was just "Victory!" - doubt that was it but I'll try next time.